4 Methoden: Excel Zählen Wenn Nicht Leer

Dieser Artikel befasst sich mit den Möglichkeiten zum Zählen nicht leerer Zellen in Excel 2019-2013. Im Folgenden finden Sie 3 Methoden zum Zählen von nicht leeren Zellen: Sie können die Zahl in der Excel-Statusleiste sehen, den Dialog Suchen und Ersetzen verwenden oder eine spezielle Formel verwenden.

Ihre Tabelle kann zur besseren Visualisierung zahlreiche leere Zellen enthalten. Auf der einen Seite ist ein solches Layout sehr praktisch. Andererseits kann es verhindern, dass Sie die korrekte Anzahl der Datenzeilen sehen.

Möglicherweise müssen Sie in Excel alle nicht leeren Zellen zählen, um zu sehen, wie viele Produkte verkauft werden oder wie viele Personen an einer Konferenz teilnehmen.

Hinweis. Wenn eine Zelle eine Formel enthält, die ein Leerzeichen zwischen Anführungszeichen (“”) liefert, wird sie nicht als leer angesehen. Ich werde sie in diesem Artikel als “leere Formeln” bezeichnen.

Methode 1: Zähloption in der Excel-Statusleiste

Die Excel-Statusleiste zeigt eine Reihe von Werkzeugen an, die Sie vielleicht hilfreich finden. Hier werden Seitenlayouts, Zoom-Schieberegler und grundlegende mathematische Funktionen für numerische Werte angezeigt.

Um zu sehen, wie viele markierte Zellen Daten enthalten, schauen Sie einfach auf die Option ZAEHLEN in der Statusleiste.

Hinweis. Diese Option funktioniert nicht, wenn Sie nur eine gefüllte Zelle im ausgewählten Bereich haben.

Sehen Sie sich einfach die Option ZÄHLEN in der Statusleiste an

Methode 2: Excel – Zählen nicht leerer Zellen mit der Option Suchen und Ersetzen

Es ist auch möglich, nicht leere Zellen mit Hilfe des Excel-Standarddialogs “Suchen und Ersetzen” zu zählen. Diese Methode ist gut, wenn Sie eine große Tabelle haben.

Sie bekommen alle Werte zusammen mit ihren Zelladressen in einem Fenster angezeigt. Außerdem können Sie leicht zu jedem Element navigieren, indem Sie auf seinen Namen in der Liste klicken.

  • Wählen Sie den Bereich aus, in dem Sie die Nicht-Leerzeichen zählen möchten, und drücken Sie die Tastenkombination Strg + F.
  • Es wird das Dialogfeld Suchen und Ersetzen angezeigt. Geben Sie das Sternchen-Symbol ( * ) in das Feld Suchen nach ein.
Geben Sie das Sternchen-Symbol ( * ) in das Feld Suchen nach ein.
  • Drücken Sie die Schaltfläche Optionen und wählen Sie in der Einblendliste Suchen in: die Option Werte oder Formeln.
    • Wenn Sie Werte wählen, zählt das Werkzeug alle gefüllten Zellen und ignoriert leere Formeln.
    • Wenn Sie Formeln wählen, zeigt Suchen und Ersetzen alle Zellen an, die Werte und irgendwelche Formeln enthalten.
  • Klicken Sie auf Alle suchen, um die Ergebnisse zu sehen. Sie erhalten alle gefundenen Artikel und deren Anzahl im Fenster.

Tipp. Sie können jetzt alle gefundenen Elemente im Fenster “Suchen und Ersetzen” auswählen. Sie sehen alle nicht leeren Zellen hervorgehoben und es bleibt, nachdem Sie das Fenster geschlossen haben.

Methode 3: Verwenden Sie eine spezielle Excel-Formel, um alle nicht leeren Zellen zu zählen

Die dritte Möglichkeit, die Anzahl der nicht leeren Zellen zu berechnen, besteht darin, eine Excel-Formel zu verwenden. Sie sehen zwar nicht, wo sich die Zellen befinden, aber diese Option hilft Ihnen bei der Auswahl der Arten von gefüllten Zellen, die Sie zählen möchten.

Siehe auch:  [Gelöst] Excel Spalte Alphabetisch Sortieren

ANZAHL2-Funktion

Wenn Sie alle gefüllten Zellen, Konstanten, Formeln, Zellen mit Leerzeichen zählen wollen, sollten Sie die Formel =ANZAHL2() verwenden.

=ANZAHL2()

Um die Anzahl der Zellen mit Konstanten und solchen mit Leerzeichen zu erhalten, geben Sie ein

=ZEILEN(G2:G11) * SPALTEN(G2:G11)-ANZAHLLEEREZELLEN(G2:G11)

Gehen Sie folgendermaßen vor, um die Formeln anzuwenden:

  1. Wählen Sie eine beliebige leere Zelle in Ihrem Blatt.
  2. Geben Sie =ANZAHL2() oder =ZEILEN() * SPALTEN()-ANZAHLLEEREZELLEN() in die Formelleiste ein.
  3. Dann können Sie die Bereichsadresse manuell zwischen den Klammern in Ihre Formel eingeben. Oder setzen Sie den Mauszeiger zwischen die Klammern und markieren Sie den gewünschten Zellbereich in Ihrer Tabelle. Sie werden sehen, dass die Adresse automatisch in der Formel erscheint.
ANZAHL2-Funktion

Mit der Forme =ZEILEN(G2:G11) * SPALTEN(G2:G11)-ANZAHLLEEREZELLEN(G2:G11) müssen Sie die Bereichsadresse 3 mal eingeben.

Mit der Forme =ZEILEN(G2:G11) * SPALTEN(G2:G11)-ANZAHLLEEREZELLEN(G2:G11) müssen Sie die Bereichsadresse 3 mal eingeben.

4. Drücken Sie die Eingabetaste auf Ihrer Tastatur.

Sie sehen das Ergebnis in der ausgewählten Zelle.

Wenn Sie nur Konstanten ohne Zellen mit zusätzlichen Leerzeichen zählen möchten, verwenden Sie

=SUMME(--(LÄNGE(GLÄTTEN(Bereich))>0)) 

Bitte beachten Sie, dass es sich hierbei um eine Array-Formel handelt, die mit STRG + Umschalt + Enter eingegeben werden muss.

  1. Wählen Sie eine beliebige leere Zelle in Ihrem Blatt.
  2. Geben Sie =SUMME(–(LÄNGE(GLÄTTEN(G2:G11))>0)) in der Formelleiste ein.
  3. Setzen Sie den Mauszeiger zwischen die Klammern und wählen Sie den Bereich in Ihrer Tabelle aus. Sie sehen, dass die Bereichsadresse in der Formel erscheint.
image 495

4. Drücken Sie Strg + Umschalt + Enter, um die Zahl in der ausgewählten Zelle zu sehen.

ZÄHLENWENN in Excel – zählen, wenn nicht leer, größer als, doppelt oder eindeutig

werden wir uns auf die Excel-Funktion ZÄHLENWENN konzentrieren, die für das Zählen von Zellen mit der von Ihnen angegebenen Bedingung gedacht ist.

Zuerst werden wir kurz die Syntax und die allgemeine Verwendung besprechen, und dann gebe ich eine Reihe von Beispielen und warne vor möglichen Macken bei der Verwendung dieser Funktion mit mehreren Kriterien und bestimmten Zelltypen.

Im Wesentlichen sind die ZÄHLENWENN-Formeln in allen Excel-Versionen identisch, sodass Sie die Beispiele aus diesem Tutorial in Excel 2019, 2016, 2013, 2010 und 2007 verwenden können.

Syntax und Verwendung

Die Excel-Funktion ZÄHLENWENN wird zum Zählen von Zellen innerhalb eines bestimmten Bereichs verwendet, die ein bestimmtes Kriterium oder eine Bedingung erfüllen.

Sie können z. B. eine ZÄHLENWENN-Formel schreiben, um herauszufinden, wie viele Zellen in Ihrem Arbeitsblatt eine Zahl enthalten, die größer oder kleiner als die von Ihnen angegebene Zahl ist. Eine weitere typische Verwendung von ZÄHLENWENN in Excel ist das Zählen von Zellen, die ein bestimmtes Wort enthalten oder mit einem bestimmten Buchstaben beginnen.

Die Syntax der ZÄHLENWENN-Funktion ist sehr einfach:

ZÄHLENWENN(Bereich, Kriterien)

Wie Sie sehen, gibt es nur 2 Argumente, die beide erforderlich sind:

  • Bereich – definiert eine oder mehrere Zellen, die gezählt werden sollen. Sie geben den Bereich in einer Formel an, wie Sie es normalerweise in Excel tun, z. B. G2:G11.
  • Kriterien – definiert die Bedingung, die der Funktion sagt, welche Zellen gezählt werden sollen. Es kann eine Zahl, eine Textzeichenfolge, ein Zellbezug oder ein Ausdruck sein. Sie können die Kriterien z. B. wie folgt verwenden: “10”, G2, “>=10”, “irgendein Text”.
Siehe auch:  (Schnell & Einfach) Excel Zeilenumbruch in Zelle

Beispiel:

=ZÄHLENWENN(G2:G11, "0%")
Syntax und Verwendung ~ ZÄHLENWENN-Funktion

Hinweis. Ein Kriterium ist unabhängig von der Groß-/Kleinschreibung.

Beispiele für die Excel-Funktion ZÄHLENWENN

Wie Sie gerade gesehen haben, ist die Syntax der ZÄHLENWENN-Funktion sehr einfach. Sie erlaubt jedoch viele mögliche Variationen der Kriterien, einschließlich Platzhalterzeichen, die Werte anderer Zellen und sogar andere Excel-Funktionen.

Diese Vielfalt macht die ZÄHLENWENN-Funktion wirklich mächtig und für viele Aufgaben geeignet, wie Sie in den folgenden Beispielen sehen werden.

Beispiel 1: ZÄHLENWENN-Formel für Text und Zahlen (exakte Übereinstimmung)

Wir haben vorhin die Funktion ZÄHLENWENN besprochen, die Textwerte zählt, die genau einem bestimmten Kriterium entsprechen. Ich erinnere Sie an die Formel für Zellen, die eine exakte Textfolge enthalten: =ZÄHLENWENN(G2:G11, “0%”). Also, Sie geben ein:

  • Einen Bereich als ersten Parameter;
  • Ein Komma als Begrenzungszeichen;
  • Ein Wort oder mehrere Wörter, die in Anführungszeichen eingeschlossen sind, als Kriterium.

Anstatt Text einzugeben, können Sie einen Verweis auf eine beliebige Zelle verwenden, die dieses Wort oder diese Wörter enthält, und erhalten absolut die gleichen Ergebnisse, z. B. =ZÄHLENWENN(H1:H11,H7).

Ähnlich funktionieren ZÄHLENWENN-Formeln für Zahlen. Wie im Screenshot unten gezeigt, zählt die Formel =ZÄHLENWENN(H1:H11,5) perfekt die Zellen mit der Menge 5 in Spalte H.

zählt die Formel =ZÄHLENWENN(H1:H11,5) perfekt die Zellen mit der Menge 5 in Spalte H.
Beispiel 2: ZÄHLENWENN-Formeln mit Platzhalterzeichen (Teilübereinstimmung)

Für den Fall, dass Ihre Excel-Daten mehrere Variationen des/der zu zählenden Schlüsselworts/Schlüsselwörter enthalten, können Sie ein Platzhalterzeichen verwenden, um alle Zellen zu zählen, die ein bestimmtes Wort, eine Phrase oder Buchstaben als Teil des Zellinhalts enthalten.

Angenommen, Sie haben eine Liste von Aufgaben, die verschiedenen Personen zugewiesen sind, und Sie möchten die Anzahl der Aufgaben wissen, die Brown John zugewiesen sind. Da John Name auf verschiedene Arten geschrieben wird, geben wir “*Brown*” als Suchkriterium ein =ZÄHLENWENN(I2:I11, “*Brown*“).

Ein Sternchen (*) wird verwendet, um Zellen mit einer beliebigen Folge von führenden und nachgestellten Zeichen zu finden

Ein Sternchen (*) wird verwendet, um Zellen mit einer beliebigen Folge von führenden und nachgestellten Zeichen zu finden, wie im obigen Beispiel gezeigt. Wenn Sie ein einzelnes Zeichen abgleichen müssen, geben Sie stattdessen ein Fragezeichen (?) ein, wie unten gezeigt.

Tipp. Es ist auch möglich, Platzhalter mit Zellbezügen mit Hilfe des Verkettungsoperators (&) zu verwenden. Anstatt z. B. “*Brown*” direkt in die Formel einzugeben, können Sie es in eine Zelle, z. B. J1, eingeben und die folgende Formel verwenden, um Zellen zu zählen, die “Braun” enthalten:

=ZÄHLENWENN(I2:I11, "*" & J1 & "*")
Beispiel 3: Zellen zählen, die mit bestimmten Zeichen beginnen oder enden

Sie können entweder ein Platzhalterzeichen, einen Stern (*) oder ein Fragezeichen (?) verwenden, wobei das Kriterium davon abhängt, welches Ergebnis Sie genau erreichen wollen.

Wenn Sie die Anzahl der Zellen wissen wollen, die mit einem bestimmten Text beginnen oder enden, unabhängig davon, wie viele andere Zeichen eine Zelle enthält, verwenden Sie diese Formeln:

=ZÄHLENWENN(I2:I11, “Mr*”) – zählt die Zellen, die mit “Mr” beginnen.

=ZÄHLENWENN(I2:I11, “*in”) – zählt die Zellen, die mit den Buchstaben “in” enden.

Wenn Sie nach einer Zählung der Zellen suchen, die mit bestimmten Buchstaben beginnen oder enden und genau die Anzahl der Zeichen enthalten, verwenden Sie die Excel-Funktion COUNTIF mit dem Fragezeichenzeichen (?) in den Kriterien:

  • =ZÄHLENWENN(I2:I11,”??own“) – zählt die Anzahl der Zellen, die mit den Buchstaben “own” enden und genau 5 Zeichen in den Zellen I2 bis I11 enthalten, einschließlich Leerzeichen.
  • =ZÄHLENWENN(I2:I11, “Mr??????“) – zählt die Anzahl der Zellen, die mit den Buchstaben “Mr” beginnen und genau 8 Zeichen in den Zellen I2 bis I11 enthalten, einschließlich Leerzeichen.
Siehe auch:  3 Methoden: Excel Datei mit Passwort Schützen

Tipp. Um die Anzahl der Zellen zu ermitteln, die tatsächlich ein Fragezeichen oder einen Stern enthalten, geben Sie eine Tilde (~) vor dem Zeichen ? oder * in die Formel ein. Zum Beispiel zählt =ZÄHLENWENN(I2:I11, “*~?*“) alle Zellen, die das Fragezeichen im Bereich I2:I11 enthalten.

Beispiel 4: Excel ZÄHLENWENN für leere und nicht leere Zellen

Diese Formelbeispiele zeigen, wie Sie die Funktion ZÄHLENWENN in Excel verwenden können, um die Anzahl der leeren bzw. nicht leeren Zellen in einem angegebenen Bereich zu zählen.

ZÄHLENWENN nicht leer

In einigen anderen Excel-ZÄHLENWENN-Tutorials stoßen Sie vielleicht auf Formeln zum Zählen nicht leerer Zellen in Excel, die dieser ähnlich sind:

ZÄHLENWENN(Bereich, "*")

Tatsache ist aber, dass die obige Formel nur Zellen zählt, die irgendwelche Textwerte enthalten, was bedeutet, dass Zellen mit Datumsangaben und Zahlen als leere Zellen behandelt werden und nicht in die Zählung eingehen!

Wenn Sie eine universelle ZÄHLENWENN-Formel zum Zählen aller nicht-leeren Zellen in einem bestimmten Bereich benötigen, hier ist sie:

ZÄHLENWENN(Bereich,"<>")

Oder

ZÄHLENWENN(Bereich,"<>" & "")

Diese Formel arbeitet korrekt mit allen Werttypen – Text, Datum und Zahlen.

ZÄHLENWENN leer

Wenn Sie das Gegenteil wollen, d. h. leere Zellen in einem bestimmten Bereich zählen, sollten Sie den gleichen Ansatz verfolgen – verwenden Sie eine Formel mit einem Platzhalterzeichen für Textwerte und mit dem Kriterium “”, um alle leeren Zellen zu zählen.

Formel zum Zählen von Zellen, die keinen Text enthalten:

ZÄHLENWENN(Bereich,"<>" & "*")

Da ein Stern (*) auf eine beliebige Folge von Textzeichen passt, zählt die Formel Zellen, die nicht gleich * sind, d. h. keinen Text im angegebenen Bereich enthalten.

Universelle ZÄHLENWENN-Formel für Leerzeichen (alle Wertetypen):

ZÄHLENWENN(Bereich,"")
Beispiel 5: ZÄHLENWENN größer als, kleiner als oder gleich

Um Zellen zu zählen, deren Werte größer, kleiner oder gleich der von Ihnen angegebenen Zahl sind, fügen Sie einfach einen entsprechenden Operator zu den Kriterien hinzu, wie in der folgenden Tabelle gezeigt.

Bitte beachten Sie, dass in ZÄHLENWENN-Formeln ein Operator mit einer Zahl immer in Anführungszeichen gesetzt wird.

Kriterium Formel Beispiel Beschreibung
Zählen, wenn größer als =ZÄHLENWENN(A2:A10,”>5″) Zählt Zellen, deren Wert größer als 5 ist.
Zählen, wenn kleiner als =ZÄHLENWENN(A2:A10,”<5″) Zählt Zellen mit Werten kleiner als 5.
Zählen, wenn gleich =ZÄHLENWENN(A2:A10,”=5″) Zählt Zellen, deren Wert gleich 5 ist.
Zählen, wenn nicht gleich =ZÄHLENWENN(A2:A10,”<>5″) Zählt die Zellen, deren Wert ungleich 5 ist.
Zählen, wenn größer oder gleich =ZÄHLENWENN(C2:C8,”>=5″) Zählt die Zellen, in denen der Wert größer oder gleich 5 ist.
Zählen, wenn kleiner oder gleich =ZÄHLENWENN(C2:C8,”<=5″) Zählt die Zellen, in denen der Wert kleiner oder gleich 5 ist.

Sie können alle obigen Formeln auch verwenden, um Zellen auf der Basis eines anderen Zellwerts zu zählen, Sie müssen dann nur die Zahl in den Kriterien durch einen Zellbezug ersetzen.

Hinweis. Im Falle eines Zellbezugs müssen Sie den Operator in Anführungszeichen setzen und ein kaufmännisches Und (&) vor dem Zellbezug hinzufügen.

Wenn Sie Zellen zählen wollen, die einen tatsächlichen Operator als Teil des Zellinhalts enthalten, also die Zeichen “>”, “<” oder “=”, dann verwenden Sie ein Platzhalterzeichen mit dem Operator in den Kriterien. Solche Kriterien werden dann als Textstring und nicht als numerischer Ausdruck behandelt